Display error with our fiat wallets balances

Incident Report for Bitpanda

Resolved

This incident has been resolved.
Posted May 09, 2022 - 10:04 CEST

Identified

Errors with our FIAT wallets balances are happening right now.
Our developers are already working to provide a solution.
Please be advised that this is a display error, and your account balance is not affected.
We are sorry for any inconvenience caused.
Posted May 06, 2022 - 15:16 CEST