IOTA/MIOTA maintenance
Incident Report for Bitpanda
Resolved
IOTA (MIOTA) are fully operational again. Thank you for your patience.
Posted Jul 12, 2021 - 17:08 CEST
Investigating
We are currently carrying out a maintenance works to improve IOTA/MIOTA performance. We are sorry for any caused inconvenience.
Posted Jul 02, 2021 - 11:26 CEST
This incident affected: Digital Assets (IOTA (MIOTA)).