Bitpanda Card activation
Incident Report for Bitpanda
Resolved
This incident has been resolved.
Posted Jul 27, 2021 - 15:16 CEST
Update
We are continuing to investigate this issue.
Posted Jul 15, 2021 - 11:03 CEST
Investigating
We are currently investigating an issue, where some of our users who have been issued a new card via their app using the re-issue function are reporting issues with the activation of their cards. The issue has already been identified, and a solution is being worked on.
Posted Jul 12, 2021 - 14:39 CEST
This incident affected: Bitpanda Card (Card Activation).