Cardano (ADA) - Maintenance
Incident Report for Bitpanda
Resolved
This incident has been resolved.
Posted Sep 12, 2021 - 12:29 CEST
Investigating
Cardano (ADA) had to be put under maintenance, due to a technical issue. Our developers are already working on a solution. Thank you for your understanding and patience.
Posted Sep 11, 2021 - 20:22 CEST
This incident affected: Digital Assets (Cardano (ADA)).