Bitpanda website unavailable

Incident Report for Bitpanda

Resolved

The issue has been resolved
Posted May 04, 2026 - 20:19 CEST

Update

A fix has been implemented and we are monitoring the results
Posted May 04, 2026 - 19:36 CEST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 04, 2026 - 19:35 CEST

Identified

The issue has been identified and a fix is being implemented.
Posted May 04, 2026 - 19:27 CEST

Investigating

At the moment we are having technical issues with the Bitpanda website. We are working on solving the issues as soon as possible. Thank you for your patience
Posted May 04, 2026 - 19:22 CEST