Fusion trading currently unavailable

Incident Report for Bitpanda

Resolved

This incident has been resolved.
Posted Jun 21, 2026 - 16:15 CEST

Investigating

At the moment we are having technical issues with the Fusion trading. We are working on solving the issues as soon as possible. Thank you for your patience.
Posted Jun 21, 2026 - 15:57 CEST
This incident affected: Fusion (Fusion).