Klarna Deposits - Service Interruption

Incident Report for Bitpanda

Monitoring

Klarna deposits have been re-enabled. Our development team is actively monitoring the system to confirm the resolution of the previously identified issue.
Posted Mar 27, 2025 - 14:18 CET

Investigating

We are currently experiencing a technical issue that is impacting Klarna deposits. We have temporarily disabled Klarna deposit services. Our engineering team is working diligently to identify the root cause and implement a fix. We apologize for any inconvenience this may cause and will provide updates on the resolution progress.
Posted Mar 21, 2025 - 13:34 CET