Savings Plans execution delays
Incident Report for Bitpanda
Resolved
The issue has been identified and the fix has already been implemented. All the savings plans are executed as expected right now. Thank you for your patience once again and sorry for the inconvenience.
Posted Jan 15, 2023 - 17:13 CET
Investigating
Certain number of Savings Plans may no be executed on time. Nevertheless, we are investigating it with urgency to provide an appropriate solution as soon as possible . Please subscribe to this incident to be informed about every update automatically. Sorry for the inconvenience and thank you for your patience.
Posted Jan 14, 2023 - 22:46 CET
This incident affected: Bitpanda (Payment methods).