Delays in Processing Savings Plan Deposits

Incident Report for Bitpanda

Resolved

This incident has been resolved.
Posted Oct 03, 2025 - 14:23 CEST

Investigating

We are currently experiencing delays in the processing of some savings plan deposits due to an ongoing technical issue with one of our service partners.
We’re actively working with our partner to restore normal operations and will provide updates as soon as we have more information.
Posted Sep 29, 2025 - 19:43 CEST
This incident affected: Bitpanda (Payment methods).