Hotmail Email Delivery Disruption

Incident Report for Bitpanda

Resolved

This incident has been resolved.
Posted Feb 18, 2025 - 08:28 CET

Identified

The issue has been identified and a fix is being implemented.
Posted Feb 11, 2025 - 17:38 CET

Investigating

Due to an issue on the Hotmail side, any communications sent from Bitpanda to Hotmail addresses are currently not being delivered. Our systems are operating normally, and we have confirmed there is no internal error causing these delivery failures. We are actively monitoring the situation and will provide updates as soon as we have more information from Hotmail.
Posted Feb 11, 2025 - 17:38 CET
This incident affected: Bitpanda (Notification service (SMS/Calls/Emails/Push)).