Bitpanda applications having issues

Incident Report for Bitpanda

Resolved

A fix has been deployed. All systems are operational
Posted Nov 04, 2024 - 16:20 CET

Investigating

We are currently investigating this issue.
Posted Nov 04, 2024 - 16:02 CET