New IBAN
Incident Report for Bitpanda
Resolved
We kindly ask you to continue using our new IBAN (EE427700771006334672) for performance reasons. Thank you very much for your understanding.
Posted Aug 15, 2021 - 13:40 CEST
Update
We are continuing to monitor for any further issues.
Posted Aug 12, 2021 - 16:11 CEST
Update
We are continuing to monitor for any further issues.
Posted Aug 02, 2021 - 17:56 CEST
Update
We are continuing to monitor for any further issues.
Posted Aug 02, 2021 - 17:55 CEST
Monitoring
Please note that we started to use another IBAN (EE427700771006334672). It allows us to process both your deposits and withdrawals quicker.
Posted Aug 02, 2021 - 17:42 CEST
This incident affected: Payout Methods (Bank Transfers (our new IBAN EE427700771006334672 will be used)) and Payment Methods (Bank Transfers (please use our new IBAN and also include your reference number)).