Crypto deposits are being delayed

Incident Report for Bitpanda

Resolved

This incident has been resolved.
Posted Nov 22, 2025 - 18:27 CET

Investigating

We are currently experiencing a technical issue affecting the processing of crypto deposits. As a result, some transactions may be delayed. Our team is actively investigating and working to resolve the issue as soon as possible. We apologize for any inconvenience this may cause and appreciate your patience.
Posted Nov 22, 2025 - 17:31 CET