Bitpanda savings via direct mandate
Incident Report for Bitpanda
Resolved
Savings plans are executed on time again. Thank you for your patience.
Posted Sep 13, 2021 - 16:08 CEST
Identified
Some users are affected by delayed execution of their savings plan via direct mandate. As a result, the purchase of the savings plans might happen with a 1-2 day delay. We are sorry for any circumstances.
Posted Sep 02, 2021 - 11:50 CEST
This incident affected: Payment Methods (Bitpanda Savings).