Lowered maximum deposit amount for savings plans
Incident Report for Bitpanda
Resolved
Savings plans are working as intended, every user has his personal 30 days deposit limit for savings plans.
Posted Sep 19, 2021 - 18:44 CEST
Investigating
We are aware of an issue where cancelled savings plans count toward your maximum possible deposits. Effectively, this means that you may not be able to create additional savings plans if your cancelled savings plans exceed a certain sum.

We are working hard to fix this issue in a timely manner.
Posted Sep 14, 2021 - 16:13 CEST
This incident affected: Payment Methods (Bitpanda Savings).