XYM (balance view only - trading will be possible soon)
Incident Report for Bitpanda
Resolved
This incident has been resolved.
Posted Sep 20, 2021 - 09:27 CEST
Monitoring
Please subscribe to our status page to get notified once trading is possible. Thank you.
Posted Sep 15, 2021 - 20:47 CEST
This incident affected: Digital Assets (Symbol (XYM) - trade only).