Gmail - Bitpanda emails classified as spam

Incident Report for Bitpanda

Resolved

Our partners were able to resolve the incident on their end.
Posted Mar 25, 2025 - 09:05 CET

Investigating

We are investigating reports of our emails classified as spam by Gmail. We are working on resolving the issue with our partners
Posted Mar 24, 2025 - 13:22 CET
This incident affected: Bitpanda (Notification service (SMS/Calls/Emails/Push)).