Bitpanda Card payment issue
Incident Report for Bitpanda
Resolved
This incident has been resolved.
Posted Oct 08, 2021 - 13:33 CEST
Investigating
Please be aware that there are temporary issues with Bitpanda Card payments and we are already working on a solution. Thank you for your understanding and patience.
Posted Oct 08, 2021 - 10:59 CEST
This incident affected: Bitpanda Card (Card Payments).