Temporary Issue with PayPal Deposits

Incident Report for Bitpanda

Resolved

This incident has been resolved.
Posted Apr 09, 2025 - 00:58 CEST

Investigating

We are currently experiencing technical difficulties on PayPal's side, which may result in issues when attempting to deposit funds using PayPal.

If you are impacted by this, please try again later. We are in close contact with PayPal to resolve the issue promptly and will provide updates as soon as they become available.

Thank you for your understanding and patience.
Posted Apr 08, 2025 - 22:58 CEST
This incident affected: Bitpanda (Payment methods).