Deposits from Open banking, EPS, Giropay not available due to technical issue
Incident Report for Bitpanda
Resolved
This incident has been resolved.
Posted May 15, 2023 - 15:10 CEST
Investigating
Due to technical issues deposits from Open banking, EPS, Giropay are not available on our platform. We're working on resolving the issue as soon as possible. We apologize for the inconvenience.
Posted May 15, 2023 - 14:15 CEST
This incident affected: Bitpanda (Payment methods).