Tell-a-Friend rewards payout is delayed due to a technical issue
Incident Report for Bitpanda
Resolved
The issue has been resolved. Tell-a-Friend reward payouts are resumed.
Posted Oct 27, 2023 - 21:01 CEST
Update
We are continuing to work on a fix for this issue.
Posted Oct 20, 2023 - 16:39 CEST
Identified
Tell-a-Friend rewards payout is delayed due to a technical issue.

We are working on resolving the issue and processing the reward payouts as soon as possible. Thank you for the understanding!
Posted Oct 20, 2023 - 14:55 CEST