Visa and Mastercard issue

Incident Report for Bitpanda

Resolved

This incident has been resolved.
Posted Aug 12, 2024 - 18:11 CEST

Investigating

Deposits with Visa and Mastercard are temporarily unavailable in some countries due to an issue at our partners side. Once resolved Visa and Mastercard deposits will be reenabled.
Posted Aug 12, 2024 - 17:52 CEST
This incident affected: Bitpanda (Payment methods).