Customer verifications temporarily down on mobile apps

Incident Report for Bitpanda

Resolved

This incident has been resolved.
Posted Nov 27, 2025 - 22:49 CET

Investigating

Customer verifications are temporarily not possible via our mobile applications due to a technical problem. As a workaround, we recommend users verify using the Web application at web.bitpanda.com. We sincerely apologise for the issue this incident is causing. Rest assured, we are working on a solution to restore functionality.
Posted Nov 27, 2025 - 22:02 CET
This incident affected: Bitpanda (User Verification Service).