IOTA transactions delayed
Incident Report for Bitpanda
Resolved
This incident has been resolved.
Posted Nov 19, 2021 - 20:31 CET
Identified
Unfortunately, IOTA transactions may currently experience some delays. We have already identified the issue and are working hard to fix it. Thank you for your patience.
Posted Nov 19, 2021 - 18:42 CET