Bank transfers delayed
Incident Report for Bitpanda
Resolved
This incident has been resolved.

Unfortunately, some transactions had to be cancelled and refunded. We ask all affected customers to request the withdrawals again.
We apologise for any inconvenience caused.
Posted Jan 19, 2022 - 20:45 CET
Investigating
There might be some delays with bank withdrawals initiated on 19.01. We are working on the fastest solution. Thank you for your patience and understanding.
Posted Jan 19, 2022 - 20:09 CET