Symbol (XYM) token airdrop
Incident Report for Bitpanda
Resolved
The issue has been resolved successfully. Thank you for your patience.
Posted Sep 15, 2021 - 18:07 CEST
Investigating
We are aware that the XYM airdrop amounts are incorrect and we are already working on it to distribute the correct amount as soon as possible.
Posted Sep 15, 2021 - 15:45 CEST