Savings plans delayed
Incident Report for Bitpanda
Resolved
All missed transactions have been processed and savings plans are fully operational again
Posted Oct 01, 2021 - 10:53 CEST
Investigating
Currently, savings plans show slight delays when executing trades. We are looking into it to fix the issue as soon as possible.
Posted Sep 30, 2021 - 14:05 CEST
This incident affected: Payment Methods (Bitpanda Savings).