Manual approvals
Incident Report for Bitpanda
Resolved
This incident has been resolved.
Posted Nov 15, 2021 - 13:04 CET
Update
We have already optimised the process, but please be mindful though that manual approvals still can unfortunately take up to 72 hours.
Posted Oct 15, 2021 - 16:09 CEST
Update
We are continuing to investigate this issue.
Posted Oct 06, 2021 - 20:19 CEST
Investigating
We are currently experiencing a high volume of requests due to high network traffic and you might experience delays with manual approvals. We are doing our best to process these transactions as quickly as possible. Thank you for your understanding and patience
Posted Oct 03, 2021 - 14:38 CEST