Bitpanda Helpdesk
Incident Report for Bitpanda
Resolved
The issue has been fixed with today's update. Thank you for your patience.
Posted Oct 13, 2021 - 12:17 CEST
Investigating
Please be aware that there might be minor issues accessing the content in our helpdesk widget in the web app. Our developers are already working on a solution. In the meantime you can access the content directly in support.bitpanda.com. Thank you very much for your patience.
Posted Oct 11, 2021 - 17:57 CEST