Bitcoin (BTC) in maintenance
Incident Report for Bitpanda
Resolved
We have accomplished our brief BTC maintenance. Thank you very much for your patience.
Posted Nov 18, 2021 - 13:40 CET
Investigating
Bitcoin is currently under maintenance. We are trying to make it fully functional as soon as possible. Thank you very much for your understanding and patience.
Posted Nov 18, 2021 - 12:00 CET