XLM transaction delay
Incident Report for Bitpanda
Resolved
This incident has been resolved.
Posted Dec 03, 2021 - 14:00 CET
Identified
Unfortunately, you may experience some delays while sending XLM. We are already looking into this issue and will re-enable XLM's full functionality as soon as possible. Thank you for your patience
Posted Nov 29, 2021 - 14:00 CET