Trading of several stocks halted
Incident Report for Bitpanda
Resolved
This incident has been resolved.
Posted Jan 03, 2022 - 10:15 CET
Identified
Trading of the affected stocks will resume on 3rd January 2022 at 8 am CET. Thank you for your patience.
Posted Jan 02, 2022 - 11:00 CET
Investigating
Buying and selling of stocks is currently partially not possible. We are working on it to fix the issue and will keep you up to date.
Posted Jan 02, 2022 - 10:51 CET