Delays with one of our banking partner

Incident Report for Bitpanda

Resolved

This incident has been resolved.
Posted Nov 01, 2025 - 19:13 CET

Investigating

We are currently experiencing some delays with one of our banking partners, which could affect users withdrawals.
What We’re Doing:
Our team is actively monitoring the situation and working closely with the vendor to ensure everything is resolved as swiftly as possible. We expect normal service to resume soon, and we’ll keep you posted with any updates.

Thank You for Your Patience:
We appreciate your understanding and patience while we sort this out. If you have any urgent concerns, feel free to reach out to our support team. We’re here to help!
Posted Nov 01, 2025 - 17:23 CET
This incident affected: Bitpanda (Payout methods, Card Withdrawals).