ADA trade only due to network update
Incident Report for Bitpanda
Resolved
The network update is concluded, ADA is fully operational again.
Posted Oct 20, 2021 - 19:04 CEST
Monitoring
We are working hard to stabilise ADA performance on our platform. We will re-enable transactions as soon as possible. Thank you for your patience.
Posted Oct 20, 2021 - 17:20 CEST