Possible delays with credit card payments
Incident Report for Bitpanda
Resolved
The credit card payments are fully operational again.
Posted Jun 08, 2021 - 14:19 CEST
Monitoring
Unfortunately, some of today's credit card payments may have been delayed due to an external technical issue. We are now monitoring the situation.
Posted Jun 08, 2021 - 13:11 CEST
This incident affected: Payment Methods (Credit Cards).