Email Confirmations
Incident Report for Bitpanda
Resolved
The issue was solved in the meantime and you should normally receive all confirmation emails again.

Thank you for your patience.
Posted Sep 22, 2021 - 12:19 CEST
Identified
We are currently experiencing technical problems with sending confirmation emails.
Please excuse the inconvenience that is caused by that. We are working hard to fix the issue.
Thank you for your patience
Posted Sep 22, 2021 - 11:57 CEST